1С: Управление торговлей ред. 10.3 и 1С: Управление производственным предприятием 1.3

После сравнения/объединения с файлом конфигурации необходимо отметить все элементы по подсистеме из файла, выбрав АтолОнлайн.
Снять флаги со всех элементов основной конфигурации в разделах Свойства, Справочники и Документы. В Документах необходимо оставить АТОЛ_Чек.
После объединения произвести настройки, которые описаны ниже.

Добавление кнопок

Документы отгрузки

  • В форму документа (Документ.РеализацияТоваровУслуг.ФормаДокумента)
    в процедуру «ПриОткрытии» в самый конец (перед «КонецПроцедуры») добавить:
//!! АТОЛ Онлайн
АТОЛ_ОбщегоНазначенияКлиент.ФормаПриОткрытии(ЭтаФорма);
//! АТОЛ Онлайн
  • В форму документа (Документ.РеализацияТоваровУслуг.ФормаДокумента)
    добавить новые процедуры (вставить текст в конце модуля формы, перед текстом «ОПЕРАТОРЫ ОСНОВНОЙ ПРОГРАММЫ»):
#Область АтолОнлайн
Процедура АтолОнлайнЗарегистрироватьПриходПолныйРасчет(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧека("full_payment", Ссылка, Организация);
КонецПроцедуры
Процедура АтолОнлайнПроверитьЧек(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ПроверитьЧек(Ссылка, Истина);
КонецПроцедуры
Процедура АтолОнлайнЗарегистрироватьПриходКредит(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧека("credit", Ссылка, Организация);
КонецПроцедуры
#КонецОбласти

Документы поступления денег

  • В форму документа оплаты в процедуру «ПриОткрытии» в самый конец (перед «КонецПроцедуры») добавить:
//!! АТОЛ Онлайн
АТОЛ_ОбщегоНазначенияКлиент.ФормаПриОткрытии(ЭтаФорма);
//! АТОЛ Онлайн
  • В форму документа оплаты добавить новые процедуры (вставить текст в конце модуля формы, перед текстом «ОПЕРАТОРЫ ОСНОВНОЙ ПРОГРАММЫ»):
#Область АтолОнлайн
Процедура АтолОнлайнЗарегистрироватьПриходПредоплата(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧекаПоОплате("full_prepayment", Ссылка, Организация);
КонецПроцедуры
Процедура АтолОнлайнПроверитьЧек(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ПроверитьЧек(Ссылка);
КонецПроцедуры
Процедура АтолОнлайнЗарегистрироватьПриходАванс(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧекаПоОплате("advance", Ссылка, Организация);
КонецПроцедуры
Процедура АтолОнлайнЗарегистрироватьПриходОплатаКредита(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧекаПоОплате("credit_payment", Ссылка, Организация);
КонецПроцедуры
#КонецОбласти

Документ возврата

  • В форму документа возврата в процедуру «ПриОткрытии» в самый конец (перед «КонецПроцедуры») добавить:
//!! АТОЛ Онлайн
АТОЛ_ОбщегоНазначенияКлиент.ФормаПриОткрытии(ЭтаФорма);
//! АТОЛ Онлайн
  • В форму документа возврата добавить новые процедуры (вставить текст в конце модуля формы, перед текстом «ОПЕРАТОРЫ ОСНОВНОЙ ПРОГРАММЫ»):
#Область АтолОнлайн
Процедура АтолОнлайнЗарегистрироватьВозврат(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧека("full_payment", Ссылка, Организация);
КонецПроцедуры
Процедура АтолОнлайнПроверитьЧек(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ПроверитьЧек(Ссылка, Истина);
КонецПроцедуры
#КонецОбласти

Документы расхода денег

  • В форму документов РасходныйКассовыйОрдер и ПлатежноеПоручениеИсходящее расхода денег в процедуру «ПриОткрытии» в самый конец (перед «КонецПроцедуры») добавить:
//!! АТОЛ Онлайн
АТОЛ_ОбщегоНазначенияКлиент.ФормаПриОткрытии(ЭтаФорма);
//! АТОЛ Онлайн
  • В форму документов РасходныйКассовыйОрдер и ПлатежноеПоручениеИсходящее расхода денег добавить новые процедуры (вставить текст в конце модуля формы, перед текстом «ОПЕРАТОРЫ ОСНОВНОЙ ПРОГРАММЫ»):
#Область АтолОнлайн
Процедура АтолОнлайнЗарегистрироватьВозврат(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧекаПоОплате("full_payment", Ссылка, Организация);
КонецПроцедуры
Процедура АтолОнлайнПроверитьЧек(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ПроверитьЧек(Ссылка, Истина);
КонецПроцедуры
#КонецОбласти
  • Для документа ОплатаОтПокупателяПлатежнойКартой в форму документа в процедуру «ДействияФормыДействиеУстановитьОперацию(Кнопка)» в самый конец (перед «КонецПроцедуры») добавить:
//!! АТОЛ Онлайн
АТОЛ_ОбщегоНазначенияКлиент.ФормаПриОткрытии(ЭтаФорма);
//! АТОЛ Онлайн
  • Для документа ОплатаОтПокупателяПлатежнойКартой в форму документа добавить новую процедуру (вставить текст в добавленную ранее область АтолОнлайн в конце модуля формы):
Процедура АтолОнлайнЗарегистрироватьВозврат(Кнопка)
АТОЛ_ОбщегоНазначенияКлиент.ВыполнитьОтправкуЧекаПоОплате("full_payment", Ссылка, Организация);
КонецПроцедуры

Картинки в формах

Картинки в формах списка

После добавления в конфигурацию рекомендуем убедиться, что в формах документа АТОЛ_Чек ФормаСписка и ФормаСпискаНовыхЧеков корректно выбраны КартинкиЗначений для полей списка:
  • Отправлен
  • Ошибка в чеке
  • Ошибка отправки
В результате в форме будут отображаться выбранные картинки